KB ID : JKB0003

 

Summary

This article describes the steps to follow on an order confirmation callback for a customer who is ordering for the first time.

 

Problem

The customer has ordered for the first time and might require help with the product price and application features.

 

Cause

Order placed by a new customer.

 

Solution

  • Call the customer and thank him for choosing Jumbotail  -> Confirm the ordered placed by the customer (Brand, Quantity & Price) -> Explain the my order & gallery features to the customer -> Explain customer through our delivery cut off and policy's -> Check if customer is finding the app to be easy and helpful -> If customer is facing any issue  -> Help the customer over the phone-> Also inform the customer that the delivery team will help him with any app related issues  -> Update ticket accordingly -> Case Closed


Important : Inform customers for any additional questions or require further clarification, please,feel free to call us at  +918880188801